Pflaugis - Arcade

Rougien mit Grafikfehler / Wackelkontakt:

Aus der Platinenkiste gegraben.... Rougien mit Grafikfehlern bzw. Wackelkontakt. Hier ein kleines Video dazu:  
© Pflaugis - Arcade 2020 / Letztes Update: 30.06.2020

Die Welt der Arcade Games....

Pac Man, Asteroids, Galaxian, Galaga, Missle Command,                    Frogger, Phoenix, Battle Zone, Hang on, Outrun...                                 ...schöne Erinnerungen an eine schöne Zeit...
Fehleranalyse: - Grafikfehler - Wackelkontakt
Bei der Rougien wurde ein defekter Sockel für das große Sub-Board gefunden, diese Sockel sind von schlechter Qualität und machen gerne mal Probleme. Hier werden alle 3 ersetzt. Dann konnte festgestellt werden, dass kurz nach dem starten eine dünne durchgehende schwarze Linie im linken Bereich zu sehen ist, die nicht normal ist. Auch beim Raumschiff wird teilweise nicht alles komplett angezeigt. Mit höherer Spannung ist das Problem verschwunden. Zur Sicherheit werden alle Eproms getestet. Hier die zerlegte Platine:
Oberseite Oberseite CIOII Oberseite SB0 Unterseite Unterseite CIOII Unterseite SB0
Die Steckverbinder zur großen Sub-Platine wurden ausgetauscht, danach war der Totalausfall behoben. Das Spiel startet nun immer und ist spielbar. Sound scheint auch OK. Es sind aber noch kleinere Grafikfehler vorhanden. Das Raumschiff wird nicht fehlerfrei dargestellt und teilweise ist eine vertikale Linie im linken Bereich über den ganzen Bildschirm zu sehen, dieses Problem ist scheinbar auch Spannungsabhängig und ändert sich wenn die 5 Volt nachgeregelt werden. Es wurden wie oben beschrieben alle Eprom geprüft. Es konnten aber keine Probleme feststellt werden. Auf Verdacht wurden einige ICs gesockelt damit sie getauscht werden konnten. Bis hier aber leider ohne Erfolg. Die Platine ist leider auch sehr schlecht zu Prüfen. Es sind auch einige dieser ECL Bauteile verbaut und hierfür habe ich keinen Ersatz um das mal schnell zu testen. Dann noch die diversen Modifikationen welche ich nicht verifizieren kann… Es gibt nur noch zwei Optionen um den Fehler zu beheben. Man könnte noch mehrere ICs auf Verdacht austauschen, z.B. alle 7 RAM ICs sockeln und ersetzen und auch noch die Steckverbinder zur kleinen Sub-Platine erneuern. Oder man könnte auch versuchen die Platine in den Originalzustand rückzubauen, dann wird die kleine Sub-Platine nicht mehr benötigt und möglicherweise sind die Grafikfehler dann weg. Allerdings ist der Aufwand recht hoch und das Ergebnis ist ungewiss… Da die Platine recht selten ist habe ich mich dann entschlossen weiter reparieren zu lassen. Mittlerweile wurde alles versucht, aber kleine Grafikfehler gibt es Stellenweise immer noch. Da ich denke dass es sich um normale “bootleg” Grafikfehler handelt, wird es so gelassen wie es ist. Das Ursprüngliche Problem bezüglich kein Bild wurde dauerhaft behoben. Hier war zumindest ein Sockel zur großen Sub-Platine gebrochen. Dann waren teilweise noch Grafikfehler vorhanden, hier wurden mehrere TTL ICs auf Verdacht ersetzt, dies konnte die Probleme aber nicht beseitigen. Dann wurde praktisch als letzte Option den Rückbau auf die Original Bestückung gemacht, das bedeutet die kleine Sub-Platine wurde entfernt und durch zwei leider teure IC F10016 ersetzt. Jetzt sind nur noch zwei ganz kleine Grafikfehler übrig geblieben die nicht 100% weg zu bekommen sind. Die Grafikfehler sind jedenfalls Spannungsabhängig, bei erhöhter + 5 Volt Spannung verschwinden diese Fehler, nach längerer Spielzeit kann das Bild dann aber unruhig werden. Wird die Spannung dann wieder verringert wird das Bild wieder ruhiger aber die zwei kleinen Grafikfehler (leichte Pixelstörung bei den „Lippen“ und jeweils im letzten Level) sind wieder zu sehen. Das Spiel wurde sehr lange geprüft und wenn die Spannung richtig eingestellt wurde war es immer problemlos spielbar.
Platine ohne Sub Sub board
Zum Abschluss wurden noch einige Elkos erneuert und alle ECL ICs wurden mit Kühlkörpern versehen. Mit +4,4 Volt läuft das Spiel einwandfrei:
Vielen Dank an Dieter für die Geduld und Reparatur ! Es hat sich gelohnt…